Get in touch
Back
Downtime

Official website is unavailable

Started 14 Apr at 04:42pm GMT+8, resolved 14 Apr at 05:21pm GMT+8.

Official Website
Resolved

A fix has been implemented and service should be back in 5 minutes

Posted 14 Apr at 05:21pm GMT+8.
Created

Official website is currently unavailable for all users. We are working to mitigate this issue. More updates to follow shortly.

Posted 14 Apr at 04:42pm GMT+8.